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1. Assignment Editor
Introduction
The complexity of today’s FPGA designs is compounded by the increasing density 
and associated pin counts of current FPGAs. It requires you to make a large number of 
pin assignments that include the pin locations and I/O standards to successfully 
implement a complex design in the latest generation of FPGAs.

To facilitate the process of entering these assignments, Altera has developed an 
intuitive, spreadsheet interface called the Assignment Editor (sometimes referred to 
as the editor in this chapter). The Assignment Editor is designed to make the process 
of creating, changing, and managing a large number of assignments as easy as 
possible.

This chapter discusses the following topics:

■ “Overview of the Assignment Editor”

■ “User Interface” on page 1–3

■ “Navigating the Assignment Editor Spreadsheet” on page 1–5

■ “Exporting and Importing Assignments” on page 1–7

■ “Creating Timing Constraints Using the Assignment Editor” on page 1–9

■ “Tcl Interface” on page 1–10

■ “Probing to Source Design Files and Other Quartus II Windows” on page 1–10

Overview of the Assignment Editor
You can use the Assignment Editor throughout the design cycle, for making either 
timing or logic assignments. Altera recommends making assignments using the 
Assignment Editor to help reduce mistakes while making assignments throughout the 
design cycle. With the editor’s dynamic syntax-checking capability, illegal 
assignments or incorrect settings can be avoided. You can also use the Assignment 
Editor to view, filter, and sort assignments based on node name or assignment type.

1 Even though the Assignment Editor allows you to make pin assignments, Altera 
recommends using the Pin Planner instead. You can use the Assignment Editor to 
view and verify the pin assignments that you have made.

The Assignment Editor is a resizable window. This scalability makes it easy to view or 
edit your assignments right next to your design files. To open the Assignment Editor, 
click the Assignment Editor icon in the toolbar, or on the Assignments menu, click 
Assignment Editor.

1 You can also launch the Assignment Editor by pressing Ctrl+Shift+A in the 
Quartus® II software.
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Overview of the Assignment Editor
The assignments made in the Assignment Editor are saved in the Quartus II Settings 
File (.qsf), which is located in the project directory. A separate .qsf file exists for each 
individual revision. Every new assignment is placed on a new line at the end of the 
.qsf file. Refer to the Quartus II Help for the syntax of the .qsf file. Refer to the 
“Viewing and Saving Assignments in the Assignment Editor” section for more details 
about how Assignment Editor handles your assignments.

Every time an assignment is created or updated, the Quartus II software displays the 
equivalent Tcl command in the System tab of the Messages window. You can use the 
displayed messages as references when making assignments using Tcl commands.

For information about exporting your assignments to a Tcl file, refer to “Tcl Interface” 
on page 1–10.

Dynamic Syntax Checking
As you enter assignments, the Assignment Editor checks for basic legality and syntax. 
This checking is not as thorough as the checks performed during compilation, but it 
rejects incorrect settings.

1 If there are incomplete assignments when you click Save on the File menu, a prompt 
gives you the choice to either save the file and lose incomplete assignments or cancel 
the save operation.

The legality status of the assignments is color coded. The color of the text in each row 
indicates if the assignment is incomplete, disabled, non-editable, or contains errors or 
warnings (Table 1–1). To customize the colors used in the Assignment Editor, on the 
Tools menu, click Options.

Viewing and Saving Assignments in the Assignment Editor
Although the Assignment Editor is the most common method of entering and 
modifying assignments, there are other methods you can use to make and edit 
assignments. For this reason, you can refresh the Assignment Editor after you add, 
remove, or change an assignment outside the Assignment Editor.

By default, all assignments made in the Quartus II software are first stored in memory, 
then to the .qsf file on the disk after you start a processing task, or if you save or close 
your project. Saving assignments to memory avoids reading and writing to your disk 
drive and improves the performance of the software.

After making assignments in the Assignment Editor, on the File menu, click Save to 
save your assignments and update the .qsf file.

Table 1–1. Description of the Color Codes in the Spreadsheet

Text Color Description

Green A new assignment can be created

Dark Yellow The assignment contains warnings, such as unknown node name

Dark Red The assignment is incomplete

Red The assignment has an error, such as an illegal value

Light Gray The assignment is disabled or turned off

Gray The assignment is non-editable or read-only
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User Interface
Starting with the Quartus II software version 5.1, you can force all assignments to be 
written to a disk drive. On the Tools menu, click Options. In the Options dialog box, 
open the Processing page and turn off Update assignments to disk during design 
processing only.

f For more information about how the Quartus II software writes to the .qsf file, refer to 
the Managing Quartus II Projects chapter in volume 2 of the Quartus II Handbook.

You can refresh the Assignment Editor window by clicking Refresh on the View 
menu. If you make an assignment using the Tcl console, Pin Planner, or directly 
modifying the .qsf file outside the Assignment Editor, you must click Refresh to 
update the Assignment Editor spreadsheet.

1 If the .qsf file is edited while the project is open, on the File menu, click Save Project 
to ensure that you are editing the latest .qsf file.

Each time the Assignment Editor is refreshed, the following message is displayed in 
the System tab of the Messages window:

Info: Assignments reloaded -- assignments updated outside Assignment 
Editor

User Interface
The Assignment Editor window consists of four bars and a spreadsheet (Figure 1–1). 
The spreadsheet is where you view and edit the assignments. You can use the bars to 
filter, edit, or get detailed information about the assignments.

You can hide all four bars in the View menu if desired, or you can collapse all the bars 
for a better view of the spreadsheet. Table 1–2 provides a brief description of each bar.

Figure 1–1. The Assignment Editor Window
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User Interface
Category Bar
The Category bar lists all assignment categories available for the selected device. You 
can use the Category bar to select a particular type of assignment and filter out all 
other assignments, making the spreadsheet show only the applicable assignments. 
For example, to view all tSU (setup time) assignments in your project, select tsu in the 
Category list. If you select All in the Category list, the Assignment Editor displays all 
assignments.

When you collapse the Category bar, three buttons are displayed that allow you to 
select from various preset categories (Figure 1–2). For example, clicking the Timing 
button changes the spreadsheet to show only the timing-related assignments of your 
project.

Node Filter Bar
The Node Filter bar is used when you want the spreadsheet to show only 
assignments for specific nodes based on the list of selected node filters. The bar 
provides flexibility in how you view and make your settings.

For example, when Show assignments for specific nodes is turned on, the 
spreadsheet shows only assignments for nodes that match the selected node filter. You 
can create a new node filter by using the Node Finder to select a node name or by 
typing the node name. The node name filter can be a node name or assignment group, 
and can include wildcard symbols (* and ?). The wildcards symbols are used to filter 
for a selection of nodes with only one entry in the Node Filter. For more information 
about wildcard symbols and assignment groups, refer to “Navigating the Assignment 
Editor Spreadsheet” on page 1–5.

Information Bar
The Information bar provides a brief description of the currently selected cell and 
what information you should enter into the cell. For example, the Information bar 
describes whether a cell should contain a node name or a number value.

Edit Bar
The Edit bar is an efficient way to enter a value into one or more spreadsheet cells. To 
change the contents of multiple cells at the same time, select the cells in the 
spreadsheet, then type or choose the new value in the Edit field in the Edit bar.

Table 1–2. Assignment Editor Bar Descriptions

Bar Name Description

Category Lists the types of available assignments

Node Filter Lists a selection of design nodes to be viewed or assigned

Information Displays a description of the selected assignment

Edit Allows you to edit the text in the selected cell(s)

Figure 1–2. Collapsed Category Bar 
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Navigating the Assignment Editor Spreadsheet
Assignment Spreadsheet
The spreadsheet displays the assignments of your project. You can sort columns, use 
pull-down list boxes to view available options, and copy and paste multiple cells into 
the Assignment Editor. Refer to “Entering Values into the Spreadsheet” for details 
about ways to make assignments in the spreadsheet.

When you enter an assignment, the font color of the row changes to indicate the status 
of the assignment. For more information, refer to “Dynamic Syntax Checking” on 
page 1–2.

The spreadsheet also supports customizable columns that allow you to show, hide, 
and arrange columns. For more information, refer to “Customizing the Spreadsheet 
Columns” on page 1–7.

Toolbar
The Assignment Editor’s toolbar contains shortcut buttons for easy access to the 
editor’s features. Figure 1–3 describes the buttons in the toolbar.

Navigating the Assignment Editor Spreadsheet
This section describes methods for navigating through the spreadsheet.

Entering Values into the Spreadsheet
There are many ways to select or enter nodes into the spreadsheet, including the Node 
Finder, the Node Filter bar, the Edit bar, or by directly typing the node name into a cell 
in the spreadsheet.

Figure 1–3. Description of Icons in the Toolbar

Detach the Assignment Editor window

Delete value in selected cells

Remove selected rows from the spreadsheet

Refresh the spreadsheet

Full screen view

Open the Customize Columns dialog box

Show all assignable pin numbers

Show all known pin names

Hide or show Category bar

Hide or show Node Filter bar

Hide or show Information bar

Hide or show Edit bar

Move cursor to the last row for new entry
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Navigating the Assignment Editor Spreadsheet
1 To open the Node Finder, click Node Finder in the Edit menu, or right-click any cell in 
the spreadsheet or the Node Filter bar and click Node Finder. Alternatively, you can 
click Node Finder in the pull-down menu of the To and From columns in the 
spreadsheet.

A node type icon is shown beside each node name and filter to identify its type. 
Table 1–3 lists the different ions and describes its type.

Wildcards
To simplify the tasks of making many node assignments, the Quartus II software 
accepts the * and ? wildcard characters. Use these wildcard characters to reduce the 
number of individual assignments you need to make for your design.

The * wildcard character matches any string. For example, given an assignment made 
to a node specified as reg*, the Assignment Editor applies the assignment to all 
design nodes that match the prefix reg with none, one, or several characters 
following the prefix, such as reg, reg1, reg[2], regbank, and reg12bank.

The ? wildcard character matches any single character. For example, given an 
assignment made to a node specified as reg?, the Assignment Editor applies the 
assignment to all design nodes that match the prefix reg and any single character 
following, such as reg1, rega, and reg4.

Table 1–3. Node Type Icons 

Node Type Icon Description

Input pin

Output pin

Bidirectional pin

Register

Combinational logic

Assignment group

Node name or filter that contains wildcard symbols

Instance

Missing information—probably caused by incorrect node name, or 
Analysis and Synthesis has not been performed
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Exporting and Importing Assignments
1 All assignments that support wildcards are shown in the pull-down list under the 
Assignment Name column of the Assignment Editor with “(Accepts 
wildcards/groups)” displayed beside it.

Assignment Groups
An assignment group, also known as a time group, is a collection of design nodes 
grouped together and represented as a single unit for the purpose of making 
assignments to the collection. Using assignment groups with the Assignment Editor 
provides the flexibility required for making complex assignments to a large number of 
nodes. You can also exclude specific nodes, wildcards, and assignments from an 
assignment group.

To create an assignment group, on the Assignments menu, click Assignment (Time) 
Groups. The Assignment Groups dialog box appears. You can add or delete 
members of each assignment group using wildcards in the Node Finder.

f For more information about using Assignment Groups for timing analysis, refer to the 
Quartus II Classic Timing Analyzer chapter in volume 3 of the Quartus II Handbook.

Customizing the Spreadsheet Columns
To provide more control over the display of information in the spreadsheet, the 
Assignment Editor supports customizable columns.

You can move columns, sort them in ascending or descending order, show or hide 
individual columns, and align the content of the column left, center, or right for 
improved readability.

When the Quartus II software starts for the first time, you see a pre-selected set of 
columns. For example, when the Quartus II software is first started, the Comment 
column is hidden. To show or hide any of the available columns, on the View menu, 
click Customize Columns. When you restart the Quartus II software, your column 
settings are maintained.

You can use the Comments column to document the purpose of an assignment, or to 
explain why you applied a timing or logic constraint. You can use the Enabled 
column to disable any assignment without deleting it. This feature is useful when 
performing multiple compilations with different timing constraints or logic 
optimizations.

Exporting and Importing Assignments
Designs that use the LogicLock™ hierarchical design methodology use the Import 
Assignments command to import assignments into the current project. You can also 
use the Export Assignments command to save all the assignments in your project to a 
file to be used for archiving or to transfer assignments from one project to another.

On the Assignments menu, click Export Assignments or Import Assignments to do 
the following:

■ Export your Quartus II assignments to a .qsf file.
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Exporting and Importing Assignments
■ Import assignments from a Quartus II Entity Settings File (.esf), a MAX+PLUS® II 
Assignment and Configuration File (.acf), a Synopsys Design Constraint (.sdc) file, 
a text file (.txt), or a Comma Separated Value (.csv) file.

In addition to the Export Assignments and Import Assignments dialog boxes, the 
Export command on the File menu allows you to export your assignments to a .tcl file 
or a .csv file.

You can use these file formats for many different aspects of your project. For example, 
you can use a .csv file for documentation purposes or to transfer pin-related 
information to board layout tools. The .tcl file makes it easy to apply assignments in a 
scripted design flow. The LogicLock design flow uses the .qsf file to transfer your 
LogicLock region settings.

Exporting Assignments
You can use the Export Assignments dialog box to export your Quartus II software 
assignments into a .qsf file, generate a node-level netlist file, and export 
back-annotated routing information as a Routing Constraints File (.rcf). See 
Figure 1–4.

On the Assignments menu, click Export Assignments to open the Export 
Assignments dialog box. The LogicLock design flow also uses this dialog box to 
export LogicLock regions.

f For more information about using the Export Assignments dialog box to export 
LogicLock regions, refer to the Analyzing and Optimizing the Design Floorplan chapter 
in volume 2 of the Quartus II Handbook.

On the File menu, click Export to export all assignments to a .tcl file or export a set of 
assignments to a .csv file. When you export assignments to a .tcl file, only user-created 
assignments are written to the Tcl script file; default assignments are not exported.

When assignments are exported to a .csv file, only the assignments displayed in the 
current view of the Assignment Editor are exported.

Figure 1–4. Export Assignments Dialog Box
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Creating Timing Constraints Using the Assignment Editor
Importing Assignments
The Import Assignments dialog box allows you to import Quartus II assignments 
from a .qsf file, an .esf file, an .acf file, or a .csv file (Figure 1–5).

To import assignments from any of the supported assignment files, perform the 
following steps:

1. On the Assignments menu, click Import Assignments. The Import Assignments 
dialog box appears (Figure 1–5).

2. In the File name text-entry box, type the file name or browse to the assignment 
file. The Select File dialog box appears.

3. In the Select File dialog box, select the file and click Open.

4. Click OK.

1 When you import a .csv file, the first uncommented row of the file must be in the 
exact format as it was when exported.

You can create a backup copy of your assignments before importing new assignments 
by turning on the Copy existing assignments into <revision name>.qsf.bak before 
importing option.

When importing assignments from a file, you can choose which assignment categories 
to import by following these steps:

1. Click Categories in the Import Assignments dialog box.

2. Turn on the categories you want to import from the Assignment categories list.

To select specific types of assignments to import, click Advanced in the Import 
Assignments dialog box. The Advanced Import Settings dialog box appears. You can 
choose to import instance, entity, or global assignments and select various assignment 
types to import.

f For more information about these options, refer to the Quartus II Help.

Creating Timing Constraints Using the Assignment Editor
Accurate timing constraints guide the place-and-route engine in the Quartus II 
software to help optimize your design into the FPGA. After completing a 
place-and-route, perform a static timing analysis using the Quartus II Classic Timing 
Analyzer or the Quartus II TimeQuest Timing Analyzer to analyze slack and critical 
paths in your design.

Figure 1–5. Import Assignments Dialog Box
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Tcl Interface
If you are using the Quartus II Classic Timing Analyzer, create timing constraints 
using the Assignment Editor. In the Assignment Editor, select Timing in the Category 
list to show all timing-related settings and make the desired timing assignments in the 
editor’s spreadsheet.

f For more information about the Quartus II Classic Timing Analyzer, refer to the 
Quartus II Classic Timing Analyzer chapter in volume 3 of the Quartus II Handbook.

If you are using the Quartus II TimeQuest Timing Analyzer, the TimeQuest Timing 
Analyzer uses timing assignments from a Synopsys Design Constraint (.sdc) file. 
Therefore, you must convert assignments from the .qsf format to the .sdc format 
before you can proceed with the timing analysis.

f For information about converting the timing assignments in your .qsf file to an .sdc 
file, refer to the Switching to the Quartus II TimeQuest Timing Analyzer chapter in 
volume 3 of the Quartus II Handbook.

Tcl Interface
Whether you use the Assignment Editor or another feature to create your design 
assignments, you can export them to a Tcl (.tcl) file. You can then use the .tcl file to 
reapply the settings or to archive your assignments. On the File menu, click Export to 
export your saved assignments to a .tcl file.

You can also generate a .tcl file that sets up your project and applies all the 
assignments to it. On the Project menu, click Generate Tcl File for Project to generate 
the file.

In addition, as you use the Assignment Editor to enter assignments, the equivalent Tcl 
commands are shown in the System tab of the Messages window. You can reference 
these Tcl commands to create a customized .tcl file. To copy a Tcl command from the 
System tab of the Messages window, right-click the message and click Copy.

f For more information about Tcl scripting with the Quartus II software, refer to the Tcl 
Scripting chapter in volume 2 of the Quartus II Handbook.

Probing to Source Design Files and Other Quartus II Windows
The Assignment Editor lets you cross-probe from the viewer to the source design file 
and to other windows within the Quartus II software. You can select a cell in the 
Assignment Editor spreadsheet and locate the corresponding item in another 
applicable Quartus II software window. To locate an item from the editor in another 
window, right-click the items of interest in the spreadsheet, point to Locate, and click 
the appropriate command. The following commands are available: 

■ Assignment Editor

■ Pin Planner

■ Timing Closure Floorplan

■ Chip Planner (Floorplan & Chip Editor)

■ Resource Property Editor
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■ Technology Map Viewer

■ RTL Viewer

■ Design File

Probing to the Assignment Editor from Other Quartus II Windows
You can cross-probe to the Assignment Editor from other windows within the 
Quartus II software. You can select one or more nodes or nets in another window and 
locate them in the Assignment Editor spreadsheet. This is useful when you want to 
see all assignments related to specific nodes.

You can locate nodes in the Assignment Editor from all windows within the 
Quartus II software. To locate assignments related to an element in the editor from 
other Quartus II windows, select the node or nodes in the appropriate window. For 
example, select an entity in the Entity list on the Hierarchy tab in the Project 
Navigator, or select nodes in the Timing Closure Floorplan. Next, right-click the 
selected object, point to Locate, and click Locate in Assignment Editor. The 
Assignment Editor opens, or it is brought to the foreground if it is already open.

Conclusion
As FPGAs continue to increase in density and pin count, it is essential to be able to 
quickly create and view design assignments. The Assignment Editor provides an 
intuitive and effective way of making assignments. With the spreadsheet interface 
and the Category, Node Filter, Information, and Edit bars, the Assignment Editor 
provides an efficient assignment entry solution for FPGA designers.

Referenced Documents
This chapter references the following documents:

■ Analyzing and Optimizing the Design Floorplan chapter in volume 2 of the Quartus II 
Handbook

■ Managing Quartus II Projects chapter in volume 2 of the Quartus II Handbook

■ Quartus II Classic Timing Analyzer chapter in volume 3 of the Quartus II Handbook

■ Switching to the Quartus II TimeQuest Timing Analyzer chapter in volume 3 of the 
Quartus II Handbook

■ Tcl Scripting chapter in volume 2 of the Quartus II Handbook
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Document Revision History
Document Revision History
Table 1–4 shows the revision history for this chapter.

f For previous versions of the Quartus II Handbook, refer to the Quartus II Handbook 
Archive.

Table 1–4. Document Revision History 

Date and Document 
Version Changes Made Summary of Changes

March 2009
v9.0

■ Revised and reorganized the entire chapter.

■ Added section “Probing to Source Design Files and Other 
Quartus II Windows” on page 1–10.

■ Added description of node type icons (Table 1–3).

■ Added explanation of wildcard characters.

Updated for the Quartus II 
software version 9.0 release.

November 2008
v8.1

Changed to 8½” × 11” page size. No change to content. Updated for the Quartus II 
software version 8.1.

May 2008
v8.0

Updated Quartus II software 8.0 revision and date. Updated references.
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